Showing posts with label internetan. Show all posts
Showing posts with label internetan. Show all posts

Sejarah Yahoo! Mail dan Google Mail

Selamat pagi agan dan aganwati semua, tak terasa waktu sudah menunjukkan jam 01.12, cepat kali berlalu ya gan. Tetapi walaupun waktu sudah larut namun selagi saya punya kesempatan untuk berpikir dan mencurahkan isi pikiran, saya tetap akan berusaha berbagi cendol kepada agan-agan kok, ummm kenapa larinya ke cendol ya ?, sorry maksud saya berbagi artikel gan hikhikhik, pada kesempatan kali saya akan ngebahas tentang Sejarah Yahoo! Mail dan Google Mail, gak usah basa-basi lagi mari check it out gan .

Apa Itu Yahoo! Mail ?

Yahoo! Mail adalah sebuah penyedia surat elektronik (webmail) dari Yahoo!. Ia merupakan penyedia surat elektronik terbesar di Internet, dengan jutaan pengguna. Penyaing utama Yahoo! Ialah Windows Live Hotmail, Gmail dan AOL Mail.

Pada 26 Agustus 2007, versi AJAX untuk Yahoo! Mail diperkirakan sudah lengkap dan mulai menggantikan Yahoo! Mail versi lama. Pengembangan antara muka baru ini bermula pada juli 2004, walupun adalah mungkin prototipe lain telah dimajukan sebelum itu. Pada masa ini ia serasi dengan Internet Explorer 7 dan Mozila Firefox serta Camino (sebagai sebagian rancangan Yahoo! Untuk menaiktaraf semua tampaknya supaya serasi dengan Firefox). Walaupun dapat digunakan melalui Opera dan Safari, terdapat sedikit masalah pada pengaturan letaknya. Yahoo mail bisa digunakan sebaga media pengganti sms, untuk memulai gunakan Yahoo! Mail berikut ini Cara Membuat EMAIL YAHOO! Baru Lengkap

Sejarah Yahoo! Mail dan Google Mail

Apa Itu Gmail ?

Gmail adalah layanan surel milik Google. Pengguna dapat mengakses Gmail dalam bentuk surat web HTTPS, protokol POP3 atau IMAP4. Gmail diluncurkan dengan sistem undangan dalam bentuk Beta pada 1 April 2004 dan tersedia untuk publik pada 7 Februari 2007 meski masih menyandang status Beta. Bersama seluruh produk Google Apps, layanan ini tidak lagi Beta pada 7 Juli 2009.

Denga kapasitas penyimpanan awal 1 GB per user, Gmail berhasil meningkatkan standar penyimpanan gratis surat web dari 2-4 MB yang ditawarkan para pesaingya pada waktu itu. Pesan pribadi, termasuk lampiran, dibatasi hingga 25 MB, lebih besar daripada layanan surat web lainnya. Gmail memiliki antarmuka berorientasi pencarian dan “tampilan percakapan” yang mirip dengan forum Internet. Sejumlah pengembang web mengakui Gmail adalah layanan pertama yang memakai metode pemograman Ajax. Gmail beroperasi dengan Google GFE/2.0 di Linux. Pada Juni 2012, Gmail adalah layanan surat elektronik berbasis web terbesar dengan 425 juta pengguna aktif di seluruh dunia.


Fitur

Gmail menyediakan kapasitas penyimpanan sebanyak lebih dari 7538 megabyte dan terus bertambah. Jumlah ini lebih dari jumlah yang disediakan situs lain. Seperti Yahoo! dan Hotmail, hal ini berarti para pengguna dapat menyimpan sampai ribuan surat elektronik. Sampai saat inil gmail merupakan email dengan kapasitas terbanyak.

Gmail juga mengaplikasikan teknologi pencarian Google yang memudahkan pengguna mencari sesuatu dari emmail mereka. Gmail juga menampilkan iklan yang didasarkan dari email yang diterima pengguna. Iklan tersebut hanya diperlihatkan ke pengguna Gmail dan tidak dikirimkan ke alamat eksternal.

Gmail dapat mengirimkan lampiran hingga 25 MB per email.

Salah satu dari hal baru yang ditawarkan Gmail adalah penyortiran email dalam bentuk “Conversation view”. Dengan begini email yang diterima akan diurutkan dalam bentuk percakapan, sehingga semua balasan dan topik tidak terpisah-pisah. Hal ini bisa membuat pengguna mudah untuk melihat email yang mereka dapat. Gmail kadang salah mengira email mana yang harus dikelompokkan bersama-sama, namun hal ini sudah jarang terjadi.

Salah satu perubahan baru adalah kemampuan untuk melabeli email. Sebuah email dapat mempunyai lebih dari satu label. Fitur ini berguna untuk menyortir email sesuai dengan label yang diberikannya, Google juga dapat memberikan label secara otomatis dengan sebuah filter.

Teknologi Push e-mail juga diterapkan Gmail pada perangkat iPhone dan Windows Mobile, sedangkan pada perangkat Telepon pintar (smartphone) lainnya kemampuan teknologi Push e-mail dari Gmail ini bervariasi tergantung dari aplikasi yang bisa dipasang pada Telepon pintar dari berbagai merk dan jenis, untuk memulai gunakan google mail Cara Membuat Email Baru di Gmail.
Artikel Terkait : Apa Itu Email, Sejarah, Penggunaan, Etika dan Keamanannya
Sekian artikel Sejarah Yahoo! Mail dan Google Mail semoga artikel ini dapat bermanfaat bagi pembaca dan jangan lupa tinggalin jejak ya gan.

Apa Itu Domain?, Sistem Penamaan, dan Sejarah

Ketika kita mempunyai situs, baikkah itu blog atau websites pastinya domain adalah salah satu bagian yang tidak boleh luput dari itu, namun taukah kita domain itu apa ?. Domain adalah nama situs kita, contohnya www.optimisinfo.com, optimisinfo adalah nama domain dan sedangkan .com adalah exstensi dari domain tersebut, ada banyak sekali exstensi domain, contohnya .id, .go.id, .uk, .us, .in dan banyak lagi lainnya.
Apa Itu Domain ?, Sistem Penamaan, dan Sejarah
Apa Itu Domain ?, Sistem Penamaan, dan Sejarah

Sistem Penamaan

Sistem Penamaan Domain ; SNR (bahasa inggris : (Domain Name Sistem; DNS)) adalah sebuah sistem yang menyimpan informasi tentang nama host ataupun nama domain dalam bentuk basis data tersebar (distributed database) di dalam jaringan komputer, misalkan: Internet. DNS menyediakan alamat IP untuk setiap nama host dan mendata setiap server transmisi surat (mail exchange server) yang menerima surel (email) untuk setiap domain. Menurut browser Google Chrome, DNS adalah layanan jaringan yang menerjemahkan nama situs web menjadi alamat internet.

DNS menyediakan pelayanan yang cukup penting untuk Internet, ketika perangkat keras komputer dan jaringan dengan alamat IP untuk mengerjakan tugas seperti pengalamatan dan penjaluran (routing), manusa pada umumnya lebih memilih untuk menggunakan nama host dan nama domain, contohnya adalah penunjukan sumber universal (URL) dan alamat surel. Analogi yang umum digunakan untuk menjelaskan fungsinya adalah DNS bisa dianggap seperti buku telepon internet di mana saat pengguna mengetikan www.pupara.com di peramban web maka pengguna akan diarahkan ke alamat IP 124.81.92.144 (IPV4) dan 2001:e00:d:10:3:140::83 (IPV6).

Sejarah singkat DNS

Penggunaan nama sebagai pengabstraksi alamat mesin di sebuah jaringan komputer yang lebih dikenal oleh manusia mengalahkan TCP/IP, dan kembali ke zaman ARPAnet. Dahulu, seluruh komputer di jaringan komputer menggunakan file HOSTS.TXT dari SRI (sekarang SIR International), yang memetakan sebuah alamat ke sebuah nama (secara teknis, file ini masih ada – sebagian besar sistem operasi modern menggunakannya dengan baik secara baku maupun melalui cara konfigurasi, dapat melihat Hosts file untuk menyamakan sebuah nama host menjadi sebuah alamat IP sebelum melakukan pencarian via DNS). Namun, sistem tersebut di atas mewarisi beberapa keterbatasan yang mencolok dari sisi prasyarat, setiap saat sebuah alamat komputer berubah, setiap sistem yang hendak berhubungan dengan komputer tersebut harus melakukan update terhadap file Hosts.

Dengan berkembangnya jaringan komputer, membutuhkan sistem yang bisa dikembangkan: sebuah sistem yang bisa mengganti alamat host hanya di satu tempat, host lain akan mempelajari perubahan tersebut secara dinamis. Inilah DNS.

Paul Mockapetris menemukan DNS pada tahun 1983; spesifikasi asli muncul di RFC 882 dan 883. Tahun 1987, penerbitan RFC 1034 dan RFC 1035 membuat update terhadap spesifikasi DNS. Hal ini membuat RFC 882 dan RFC 883 tidak berlaku lagi. Beberapa RFC terkini telah mempromosikan beberapa tambahan dari protokol inti DNS.

Pengertian beberapa bagian dari nama domain

Sebuah nama domain biasanya terdiri dari dua bagian atau lebih (secara teknis disebut label), dipisahkan dengan titik.

1)Label paling kanan menyatakan top level domain – domain tingkat atas (misalkan, alamat www.pupara.com memiliki top-level domain com).

2)Setiap label di sebelah kirinya menyatakan sebuah sub-divisi- atau subdomain dari domain yang lebih tinggi. Catatan: “subdomain” menyatakan ketergantungan relatif, bukan absolut. Contoh: pupara.com merupakan subdomain dari domain com, dan pupara.com dapat membentuk subdomain dari domain wikipedia.com (pada praktinya, pupara.com sesungguhnya mewakili sebuah nama host – lihat dibawah). Secara teori, pembagian seperti ini dapat mencapai kedalam 127 level, dan setiap label dapat berbentuk sampai dengan 63 karakter, selama total nama domain tidak melebihi panjang 255 karakter. Tetapi secara praktik, beberapa pendaftar nama domain (domain name registry) memiliki batas yang lebih sedikit.

3)Terakhir, bagian paling kiri dari bagian nama domain (biasanya) menyatakan nama host. Sisa dari nama domain menyatakan cara untuk membangun jalur logis untuk informasi yang dibutuhkan: nama host adalah tujuan sebenarnya dari nama sistem yang dicari alamat IP-nya. Contoh: nama domain www.pupara.com memiliki nama host “www”.

DNS memiliki kumpulan hierarki dari DNS Server. Setiap domain atau subdomain memiliki satu atau lebih authoritative DNS Server (server DNS otorisatif) yang mempublikasikan informasi tentang domain tersebut dan nama-nama server dari setiap domain di-“bawah”-nya. Pada puncak hierarki, terdapat root server- induk server nama : server yang ditanyakan ketika mencari (menyelesaikan/resolving) dari sebuah nama domain tertinggi (top-level domain).

That’s it from me, semoga dengan artikel Apa Itu Domain ?, Sistem Penamaan, dan Sejarah ini dapat menambah pengetahuan bagi pembaca dan penulis khususnya.

Sumber artikel https://id.wikipedia.org/wiki/Sistem_Penamaan_Domain

Sumber gambar hasil googling 

Apa Itu Email, Sejarah, Penggunaan, Etika, dan Keamanannya

Email atau Surat Elektronik (akronim: ratel, ratron, surel, atau surat-e) atau pos elektronik (akronim: pos-el.) atau imel (bahasa inggris: email) adalah sarana kirim mengirim surat melalui jalur jaringan komputer.

Dengan surat biasa umumnya pengirim perlu membayar per pengiriman (dengan membeli perangko), tetapi surat elektronik umumnya biaya yang dikeluarkan adalah biaya untuk membayar Internet. Tapi ada perkecualian misalnya surat elektronik ke telepon genggam, kadang pembayarannya ditagih per pengiriman.
Apa itu Email, Sejarah, Penggunaan, Etika, dan Keamanannya
Apa itu email, sejarah, penggunaan, etika, dan keamanannya

Sejarah

Surat Elektronik sudah mulai dipakai tahun 1960-an. Pada saat itu internet belum terbentuk, yang ada hanyalah kumpulan ‘mainframe’ yang terbentuk sebagai jaringan. Mulai tahun 1980-an, surat elektronik sudah bisa dinikmati oleh khalayak umum. Sekarang banyak perusahaan pos di berbagai negara menurun penghasilannya disebabkan masyarakat sudah tidak memakai jasa pos lagi.

Anatomi Ratel, sebagai contoh :

USERNAME@EXAMPLE.COM

Keterangan :

1.)Email saya: nama kotak surat (mailbox) atau nama pengguna (username) yang ingin dituju dalam mailserver

2.)Aceh.vibriel.net.id: nama mailserver tempat pengguna yang dituju, rinciannya :

2.1 Aceh: subdomain (milik pemegang nama domain), biasanya merujuk kesuatu komputer dalam lingkungan pemilik domain

2.2 Variabel: nama domain: biasanya menunjukkan nama perusahaan/organisasi/perorangan (Vibriel)

2.3 Net: second level domain, menunjukkan bahwa domain ini termasuk kategori Networking (net)

2.4 Id: top level domain, menunjukkan bahwa domain ini terdaftar di otoritas domain Indonesia (id)

Email Pertama Di Dunia 

Konsep email pertama kali dikemukakan oleh Ray Tomlinson pada akhir tahun 1971. Pada awalnya “Ray bereksperimen dengan program komputer yang bernama SNDMSG yang pada saat itu digunakan untuk meniggalkan pesan pada komputer, sehingga orang yang memakai komputer dapat membaca pesan yang ditinggalkan oleh pemakai kopmputer “saat itu normal ketika banyak orang menggunakan komputer yang sama secara bergantian”.

Eksperimen Ray kemudian dilanjutkan dengan menghubungkan SNDMSG melalui file protocol yang bernama CYPNET sehingga program SNDMSG dapat mengirimkan pesan ke komputer lain “namun masih berada dalam satu jaringan ARPAnet. Eksperimen tersebut berhasil dan itulah awal terciptanya email.

Pesan email pertama kali yang dikirim oleh Ray pada 1971 merupakan email pertama di dunia. Kemungkinan pesan pertama yang dikirimkannya adalah QWERTYUIOP atau huruf serupa, “kata Ray dalam akun Flickr miliknya. Pada tahun 1972, Ray mengenalkan lambang @ “Indonesia dibaca ET” sebagai identitas Email untuk memisahkan antara Identitas pengguna dengan domain. @ “bahasa inggris ditulis AT” artinya adalah Kepada.

Metode pengiriman

Untuk pengiriman surat elektronik kita memerlukan suatu program mail-client. Adapun skema pengiriman dimulai dari pengiriman surat elektronik -> Internet -> POP3 server penyedia e-mail penerima -> e-mail client (di komputer si penerima) -> surat elektronik dibaca oleh si penerima.

Cara membaca surat elektronik

Surat elektronik pada mulanya disimpan di dalam sebuah mailserver.

Ada dua cara untuk mengakses surat elektronik :

1.) Dengan cara menggunakan peramban web, seperti Mozila Firefox. Metode ini disebut sebagai web-base, artinya kita menggunakan media web sebagai perantara ke kotak surat elektronik. Contoh: Yahoo! Mail dan Gmail. Untuk menggunakannya, pengguna haruslah dalam keadaan daring. Layanan surat elektronik berbasis web biasanya disediakan oleh penyelenggara layanan surel gratis.

2.) Menggunakan program pengaksesan surat elektronik (e-mail client), seperti: Outlook Express, Windows Mail, Mozilla Thunderbird. Dengan menggunakan program seperti ini, seseorang harus mengetahui konfigurasi yang bisa didapat dari ISP. Keuntungannya adalah dapat membaca surat elektronik tanpa perlu terhubung dengan secara terus menerus dengan internet dan puluhan surat elektronik dapat diterima dan dikirimkan secara bersama-sama sekaligus. Kelebihan lainnya adalah perangkat lunak ini menyediakan fungsi-fungsi penyuntingan dan pembacaan surel secara luring. Dengan demikian biaya koneksi ke internet dapat dihemat.

Etika penggunaan surat elektronik

Etika dalam surat elektronik sama dengan etika dalam menulis surat biasa. Ada surat elektronik yang isinya formal ada yang informal. Beberapa point penting :

1.)Jangan mengirim surat elektronik dengan lampiran (attachment) yang terlalu besar (lebih dari 512 kb). Tidak semua orang mempunyai akses Internet yang cepat, dan ada kemungkinan lampiran tersebut melebihi kapasitas surat elektronik penerima, sehingga akan ditolak mailserver penerima. Selain itu, perhatikan juga bahwa beberapa penyedia surat elektronik juga menerapkan batasan tentang jumlah, jenis, dan ukuran surat elektronik yang dapat diterima (dan dikirim) penggunanya.

2.)Jangan mengirim lanjut (forward) surat elektronik tanpa berpikir kegunaannya bagi orang yang dituju

3.)Selalu isi kolom subjek, jangan dibiarkan kosong.

4.)Dalam mengutip tulisan orang lain, usahakan mengutip seperlunya, jangan mau gampangan mengutip seluruh tulisan orang itu:

4.1 Dalam menjawab surat elektronik orang lain, kutip bagian yang kita tanggapi saja, selain lebih jelas juga tidak memakan waktu / jatah akses penerima.

4.2 Dalam mengutip tulisan orang ketiga, ingat hak cipta : kutip sedikit mungkin dan rujuk ketulisan aslinya.

5.)Jangan gunakan huruf kapital karena dapat menimbulkan kesan anda BERTERIAK

8.)Gunakan kata-kata dengan santun. Adakalanya sesuatu yang kita tulis akan terkesan berbeda dengan apa yang sebetulnya kita maksudkan.

Keamanan

Kemanan data di surat elektronik tidaklah terjamin dan selalu ada risiko terbuka untuk umum, dalam artian semua isinya dapat dibaca oleh orang lain. Hal ini disebabkan oleh karena surat elektronik itu akan melewati banyak server sebelum sampai di tujuan. Tidak tertutup kemungkinan ada orang yang menyadap surat elektronik yang dikirimkan tersebut.

Surat elektronik dapat diamankan dengan melakukan teknik pengacakan (enkripsi). Salah program enkripsi yang populer adalah PGP (Pretty Good Privacy). Dengan memakai PGP maka isi akan dienkrip, dan hanya orang yang tertuju dapat mendeskripsikan dan membaca surat elektronik tersebut. Kerugiannya adalah membuat repot pihak pengirim dan penerima (karena keduanya harus mempunyai program PGP), dan pengirim juga harus memiliki kunci umum penerima, dan melakukan enkripsi pesan dengan kunci tersebut).

Sekian artikel tentang pengenalan Apa Itu Email, Sejarah, Penggunaan, Etika, dan Keamanannya semoga bermanfaat, dan jangan lupa tinggalin jejak berupa komentar masukan atau kritikan dari agan mengenai artikel yang saya publish ini.